Web 2.0 คืออะไร?

posted on 21 May 2009 16:22 by zeous21 in Tenology

จาก Web 2.0 Conference ครั้งที่ผ่านมา ได้มีการวาด Mime Map ขึ้นมาซึ่งแสดงให้เห็นถึงการเปลี่ยนแปลงไปสู่ Web 2.0 ได้อย่างชัดเจน

 

จากนวตกรรมใหม่ๆ และแนวคิดที่นำสิ่งที่มีอยู่แล้วมาประยุกต์ใช้ เราจึงได้รู้จัก Concept ของ Blog, tags, Ajax, podcasts เชื่อหรือไม่ concept เหล่านี้พึ่งเกิดขึ้นได้ไม่ถึงปี!!

พฤติกรรมการใช้ internet ทำให้คำว่า Web ไม่ใช่แค่ Noun อีกต่อไป แต่มันเป็น Verb เสียแล้ว เป็นการติดต่อ 2 ทาง และผู้ใช้เองนั่นและเป็นผู้สร้าง Content ไม่ใช่ Content Provider อีกต่อไป

กลับมามองที่ประเทศไทยเราบ้าง ประเทศไทยของเราตอนนี้เข้ามาถึงยุคของ Web 2.0 แล้วหรือยัง ถ้ามองที่ผู้ใช้ในความเห็นผม ถือว่าเราได้อยู่ใน Web 2.0 แล้ว ดูได้จากจำนวน Blog ที่เพิ่มขึ้นอย่างมโหฬารในช่วง 1 ปีที่ผ่านมา หรือ Photo Sharing ที่นับวันจะมีการแชร์รูปกันมากขึ้น และการแสดงความคิดเห็นตาม Content หรือ Web board ต่างๆ เห็นได้จาก Manager Online แต่หากกลับมามองที่เทคโนโลยีละ เราถึง Web 2.0 แล้วหรือยัง ... ในมุมมองของผมคือ ยัง ไม่ว่าจะทั้งทางด้านเทคโนโลยี การประยุกต์ใช้ Concept และแนวคิดต่างๆ เรายังมีให้เห็นน้อยมาก การใช้เทคนิคเช่น CSS Layout หรือ Ajax มีให้เห็นน้อยมาก หรือไม่มีเลย แนวคิดเรื่อง Tags, Podcasts ก็ไม่มีอีกเช่นกัน

ถึงเวลาแล้วหรือยังที่เราจะร่วมกันพัฒนา Web Site ของเมืองไทยเรา ให้ตรงกับความต้องการกับผู้ใช้ในประเทศ ที่ TrueLife ผมพยายามนำ Concept และแนวคิด Web2.0 มาใช้ให้มากที่สุด ทั้งที่ทำออกไปแล้ว หรือที่กำลังพัฒนาอยู่ตอนนี้ ที่ Exteen.com (นี่่ มีกับเค้าด้วยนะเนีย) ก็เป็นอีกที่หนึ่งที่ผมเฝ้าดูความพยายามอยู่เช่นกัน ผมหวังว่าพวกเราที่ Narisa.com ชุมชนของ Developer ที่แข็งแกร่งที่สุดแห่งหนึ่งในเมืองไทย จะได้ร่วมใจกันพัฒนานำทั้งเทคโนโลยี และแนวคิดใหม่ๆของ Web2.0 มาใช้ให้เกิดประโยชน์กัน และถ้าเป็นไปได้ ก็สร้างนวตกรรมใหม่ๆขึ้นมา

อย่างคำว่า white board ที่มีการกล่าวถึงใน Forum ของพวกเรา ก็เป็น concept ที่ดี ผมอยากจะสนับสนุนให้มีแนวคิดใหม่ๆแบบนี้อยู่เสมอ ผมอยากให้พวกเรามีส่วนร่วมกับประวัตศาสตร์ใหม่ที่กำลังจะมาถึงอันใกล้ ไม่ใช่รับมาแต่จากเมืองนอกอย่างเดียว พวกเรามาช่วยกันพัฒนาวงการซอฟแวร์ไทยให้ก้าวสู่ web2.0 ด้วยกันเถอะครับ และถ้าให้ดีกว่านั้น ถ้าเราสามารถก้าวแซงไปที่ web2.1 ได้ยิ่งดีครับ

 

อ้างอิงจาก www.narisa.com

Basic COnfig Qos

posted on 02 Mar 2007 07:49 by zeous21 in Tenology

ต้องเก็บไว้ครับ.... เพื่องาน

I want to apply the config below to allow all citrix (port 1494) to be

marked with the precedence bit #2. The reason for this is my serial
interface of the router at this remote location communicates through an
MPLS network that has multiple routers (managed by Qwest) that it
communicates through before it communicates with our central location.
My service provider told me to mark all citrix traffic with the
precedence value of 2 and they give it its proper priority when
communicating through their MPLS WAN.

2 questions
Does the configuration below do the job of marking citrix traffic with
precedence 2 so that the service provider can it its proper priority?
What command command can I use to make sure that Citrix never consumes
more than 65 percent of available bandwith even when available?

access-list 112 permit tcp any any precedence immediate eq 1494
!
class-map match-any citrix
match access-group 112
!
policty map citrixtraffic
class citrix
priority percent 65
!
int serial 0
service-policy output citrixtraffic

Set Config Qos in Switch

posted on 02 Mar 2007 07:22 by zeous21

CCNP Self-Study: Understanding and Implementing Quality of Service in Cisco Multilayer Switched Networks

Configuration Exercise: Configuring QoS on Cisco IOSBased Catalyst Switches
Complete this configuration exercise to familiarize yourself with basic QoS configuration on Cisco IOSbased Catalyst switches as discussed in this chapter.
Required Resources
The resources and equipment required to complete this exercise are as follows (the last two items are optional):
  • Catalyst 3550
  • Terminal server or workstation connected directly to the console port of the Catalyst 3550 or out-of-band access to the Catalyst 3550
  • Cisco IP Phones infrastructure supporting voice calls (this resource verifies the configuration and is not mandatory)
  • Traffic generator (this resource verifies the configuration and is not mandatory)
Exercise Objective
The purpose of this exercise is to configure a Cisco IOSbased Catalyst switch for the following QoS features:
  • Classification
  • Marking
  • Policing
  • Congestion management
  • Congestion avoidance
The exercise exposes topics such as VLANs and spanning tree found in others chapters of this book. Nevertheless, the main purpose of this exercise is to demonstrate a QoS configuration. In this configuration exercise, your goal is to configure a Catalyst 3550 for the following QoS features:
  • Trust ingress DSCP values for interfaces FastEthernet0/1 through 0/10 when a Cisco IP Phone is attached
  • Reclassify frames on interface FastEthernet0/11 for a CoS value of 4
  • Mark ingress TCP Port 30000 frames on interface FastEthernet0/12 with a DSCP value of16
  • Apply strict-priority queuing for VoIP traffic
  • Configure high-priority queues to have a 2-to-1 (2:1) priority over low-priority queues
Network Diagram
Figure 10-18 shows the network layout for this configuration exercise

Command List

In this configuration exercise, you will use the commands listed in Table 10-7, which are in alphabetical order so that you can easily locate the information you need. Refer to this list if you need configuration command assistance during the configuration exercise. The table includes only the specific parameters used in the example and not all the available options for the command

mls qos

Globally enables QoS

mls qos trust device cisco-phone

Interface configuration command for trusting when a Cisco Phone is learned via CDP on the respective interface; works in conjunction with the mls qos trust dscp and mls qos trust cos commands

mls qos trust dscp

Interface configuration command for trusting DSCP values for ingress frames

no shutdown

Configures an interface in the Administrative UP state

policy-map policy_map_name

Enters the policy-map configuration submode

priority-queue out

Configures queue 4 on the Catalyst 3550 family of switches as a priority queue

service-policy input | output policy-map-name

Maps a policy map to an interface for ingress or egress traffic

set ip dscp dscp_value

Policy-map class action for marking DSCP

show mls qos interface FastEthernet | GigabitEthernet interface

Displays the trusting configuration of an interface

spanning-tree portfast

Configures an interface for the spanning-tree PortFast feature

Switchport

Configures an interface for Layer 2 operation

switchport access vlan vlan-id

Configures an interface for a specific VLAN-ID

vlan vlan-id

Adds or removes a VLAN-ID in the VLAN database

wrr-queue bandwidth weight1 weight2 weight3 weight4

For weight1 weight2 weight3 weight4, enter the ratio that determines the frequency in which the WRR scheduler dequeues packets; separate each value with a space (the range is 1 to 65536)

wrr-queue cos-map queue-id cos1 ... cos8

Configures CoS value to egress queue mapping

Task 1: Globally Enable QoS

Step1 Connect the Catalyst switch to a terminal server or directly to the workstation's serial port for in-band connectivity.

Step2 Globally enable QoS features on the switch.

Switch#configure terminal
Switch(config)#mls qos

Step3 Verify that QoS is globally enabled.

Switch(config)#do show mls qos
QoS is enabled

NOTE

The Cisco IOS do command is a recent addition to Cisco IOS to allow execution of privileged mode commands within configuration mode. This command saves the time and annoyance of exiting out and re-entering configuration mode. do is only found in the most recent Cisco IOS version, so it may not be supported in your version. If not, exit configuration mode and type the command (minus the keyword do) in privileged mode.

Recall that for the Catalyst 4000 and 4500 families of switches running Cisco IOS, qos commands are not prefixed with the keyword mls.

Task 2: Configure the Switch to Trust DSCP on Interfaces FastEthernet0/1 Through 0/10 If a Cisco IP Phone Is Attached

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -10

Step2 Specify an access VLAN for IP Phones (voice VLANs are not used in this exercise).

Switch(config-if-range)#switchport access vlan 500

Step3 Configure the switch to trust DSCP for incoming frames only if Cisco IP Phones are attached to the interface.

Switch(config-if-range)#mls qos trust dscp
Switch(config-if-range)#mls qos trust device cisco-phone

Step4 Configure the interfaces for spanning-tree PortFast.

Switch(config-if-range)#spanning-tree portfast
%Warning: portfast should only be enabled on ports connected to a single
 host. Connecting hubs, concentrators, switches, bridges, etc... to this
 interface when portfast is enabled, can cause temporary bridging loops.
 Use with CAUTION
%Portfast will be configured in 10 interfaces due to the range command
 but will only have effect when the interfaces are in a non-trunking mode.

Step5 Enable the interfaces.

Switch(config-if-range)#no shutdown

Step6 Verify the QoS configuration.

Switch#show mls qos interface FastEthernet 0/1
FastEthernet0/1
trust state: not trusted
trust mode: trust dscp
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
trust device: cisco-phone

Task 3: Configure the Switch to Classify All Incoming Frames on Interface FastEthernet 0/11 with a CoS Value of 4 for Untagged Frames

Step1 Enter the interface configuration mode for FastEthernet0/11.

Switch(config)#interface FastEthernet 0/11

Step2 Configure the interface to classify all ingress frames with a CoS value of 4.

Switch(config-if)#mls qos cos 4

Step3 Verify the QoS configuration.

Switch#(config-if)#do show mls qos interface FastEthernet 0/11
FastEthernet0/11
trust state: not trusted
trust mode: not trusted
COS override: dis
default COS: 4
DSCP Mutation Map: Default DSCP Mutation Map
trust device: none

Task 4: Configure a Policy Map, Class Map, and the Interface Such That All Ingress TCP Port 30000 Packets on FastEthernet0/11 Have Their DSCP Set to 16

Step1 Configure an access list to match packets on TCP port 30000.

Switch(config)#access-list 100 permit tcp any any eq 30000

Step2 Configure a traffic profile using a class map.

Switch(config)#class-map TCP-PORT-30k
Switch(config-cmap)#match access-group 100
Switch(config-cmap)#exit

Step3 Configure a policy map to apply the class map in Step 2 to the class action of setting the DSCP to 16.

Switch(config)#policy-map BCMSN
Switch(config-pmap)#class TCP-PORT-30k
Switch(config-pmap-c)#set ip dscp 16
Switch(config-pmap-c)#exit
Switch(config-pmap)#exit

Step4 Apply the policy-map ingress on interface FastEthernet0/11.

Switch(config)#interface FastEthernet 0/11
Switch(config-if)#service-policy input BCMSN
Switch(config-if)#exit

Step5 Verify the policy-map configuration.

Switch#show policy-map interface FastEthernet 0/11

 FastEthernet0/11

 service-policy input: BCMSN

  class-map: TCP-PORT-30k (match-all)
   0 packets, 0 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   match: access-group 100

  class-map: class-default (match-any)
   0 packets, 0 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   match: any
    0 packets, 0 bytes
    5 minute rate 0 bps

Task 5: Configure All Egress Queues Such That CoS Values 4, 6, and 7 Use Queue 3 and a CoS Value of 5 Uses Queue 4

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure interfaces for appropriate CoS mapping.

Switch(config-if)#wrr-queue cos-map 4 5
Switch(config-if)#wrr-queue cos-map 3 4 6 7
Switch(config-if)#exit

Task 6: Configure Queue 4 as a Strict-Priority Queue

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure queue 4 as a strict-priority queue.

Switch(config-if)#priority-queue out

Task 7: Configure WRR Weights Such That Queue 3 Receives Twice as Much Service as Any Other Single Queue

Step1 Enter the range command to configure multiple interfaces simultaneously.

Switch(config)#interface range FastEthernet 0/1 -24

Step2 Configure queue 3 with twice the service level as that of any other queue.

Switch(config-if)#wrr-queue bandwidth 20 20 40 20

Step3 Verify the WRR configuration.

Switch#show mls qos interface FastEthernet 0/1 queueing
FastEthernet0/1
Egress expedite queue: ena
wrr bandwidth weights:
qid-weights
 1 - 20
 2 - 20
 3 - 40
 4 - 20  when expedite queue is disabled
Cos-queue map:
cos-qid
 0 - 1
 1 - 1
 2 - 2
 3 - 2
 4 - 3
 5 - 4
 6 - 3
 7 - 3

Task 8: Verify All Configurations by Viewing Interface Statistics

Switch#show mls qos interface FastEthernet 0/1 statistics
FastEthernet0/1
Ingress
 dscp: incoming  no_change classified policed  dropped (in bytes)
Others: 97663325  87828650  9834675  0     0
Egress
 dscp: incoming  no_change classified policed  dropped (in bytes)
Others: 30540345   n/a    n/a   0     0